Superuser

Autor Thema: mod_wsgi übersetzen  (Gelesen 4547 mal)

Offline linus83

  • Sobl Bachelor
  • ***
  • Beiträge: 144
mod_wsgi übersetzen
« am: 16. Februar 2009, 20:44:55 »
Hallo,

ich sitze anscheint gerade auf den schlauch. Ich möchte mod_wsgi für den Apachen übersetzten.

root mod_wsgi-2.3 $ ./configure
checking for apxs2... no
checking for apxs... /usr/bin/apxs
checking Apache version... 2.2.9
checking for python... /usr/bin/python
configure: creating ./config.status
config.status: creating Makefile
root mod_wsgi-2.3 $ make
/usr/bin/apxs -c -I/usr/include/python2.4 -DNDEBUG  mod_wsgi.c -L/usr/lib/python2.4/config -lpython2.4 -lsocket -lnsl -ldl
/usr/apr/1.3/build/libtool --silent --mode=compile /opt/SUNWspro/bin/cc -prefer-pic -xO3 -m32 -xchip=pentium -xspace -Xa -xildoff -xc99=all -DSSL_EXPERIMENTAL -DSSL_ENGINE -xO4  -DSOLARIS2=11 -D_POSIX_PTHREAD_SEMANTICS -D_REENTRANT -mt -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64  -I/usr/apache2/2.2/include  -I/usr/apr/1.3/include   -I/usr/apr-util/1.3/include  -I/usr/include/python2.4 -DNDEBUG  -c -o mod_wsgi.lo mod_wsgi.c && touch mod_wsgi.slo
env: No such file or directory
apxs:Error: Command failed with rc=65536
.
*** Error code 1
make: Fatal error: Command failed for target `mod_wsgi.la'
root mod_wsgi-2.3 $

Hat wer eine Idee? Das ist sicher trivial, aber ich finde das Problem nicht wirklich, was er mit env hat. Es ist ein Open Solaris 2008.11 Build 106 und python (/usr/bin/python) ist in der Version 2.4.4 installiert.

Gruß
« Letzte Änderung: 16. Februar 2009, 21:03:24 von linus83 »

sonnenblen.de - Das unabhängige Sun User Forum

mod_wsgi übersetzen
« am: 16. Februar 2009, 20:44:55 »

linuxdomination

  • Gast
Re: mod_wsgi übersetzen
« Antwort #1 am: 24. Februar 2009, 12:55:32 »
der env error ist eher übergeordnet, deutet auf ein verhunztes solaris environment hin unschön aber unkritisch, allso eher nicht die ursache deines problems.

apxs:Error: Command failed with rc=65536 --> http://anyterm.org/forums/viewtopic.php?id=60


Offline linus83

  • Sobl Bachelor
  • ***
  • Beiträge: 144
Re: mod_wsgi übersetzen
« Antwort #2 am: 24. Februar 2009, 22:17:13 »
Ich werde daraus irgendwie nicht schlau  ??? ???

Naja verhuzt ist nichts, ehr nicht eingerichtet. Ich habe die default-Variablen und einige Änderungen. Auf einen "sauberen" System (Bootumgebung, nach der Installation) ist der selbe Fehler. Hat wer ein System auf den es geht oder Ideen wie Umgebungsvariablen gesetzt sein müssen?

libtool ist seit Build 99 nicht mehr im apache-Packet. Das libtool von Solaris ist in der Version 1.5.26 kann das ein Grund sein?
« Letzte Änderung: 25. Februar 2009, 08:43:55 von linus83 »