Superuser

Autor Thema: Solaris 10 x86 serial console  (Gelesen 5751 mal)

Radler

  • Gast
Solaris 10 x86 serial console
« am: 11. Februar 2010, 08:22:30 »
Schönen guten Morgen an alle!


Auf einem x86 Rechner habe ich Solaris 10 x86 10/09 mit gespiegeltem ZFS RootPool installiert. Bei einrichten der seriellen Console habe ich so meine Probleme.
Ich habe die menu.lst bearbeitet (console-parameter rein, bootsplash raus) und die Konfiguration mit eeprom console="ttya"; eeprom input-device="ttya"; eeprom output-device="ttya" (diese Parameter stehen dann auch in der /boot/solaris/bootenv.rc) durchgeführt.

Jetzt sehe ich den Grub und die nachfolgenden Ausgaben auf der Console bis hin zum Login.
Leider kann ich keine Eingaben machen und die Ausgabe "Solaris 10 Console Login:" erscheint im Sekundentakt mit vielen Zeichen dahinter (meist "Y" mit Ü-Punkten).

Ich hoffe ihr könnt mir helfen!!!



Hier noch Ausgaben vom System:

-bash-3.00# eeprom
ata-dma-enabled=1
atapi-cd-dma-enabled=0
ttyb-rts-dtr-off=false
ttyb-ignore-cd=true
ttya-rts-dtr-off=false
ttya-ignore-cd=true
ttyb-mode=9600,8,n,1,-
ttya-mode=9600,8,n,1,-
lba-access-ok=1
prealloc-chunk-size=0x2000
keyboard-layout=US-English
console=ttya
input-device=ttya
output-device=ttya

Auszug aus /rpool/boot/grub/menu.lst:
...
serial --unit=0 --speed=9600
terminal --timeout=20 serial console
...
title Solaris 10 10/09 s10x_u8wos_08a X86
findroot (pool_rpool,0,a)
kernel$ /platform/i86pc/multiboot -B console=ttya,$ZFS-BOOTFS
module /platform/i86pc/boot_archive

« Letzte Änderung: 15. Februar 2010, 09:32:06 von Radler »

sonnenblen.de - Das unabhängige Sun User Forum

Solaris 10 x86 serial console
« am: 11. Februar 2010, 08:22:30 »