Autor Thema: Frage zu Cron  (Gelesen 3297 mal)

Offline avalox

  • Sobl Junior
  • **
  • Beiträge: 59
Frage zu Cron
« am: 09. August 2012, 10:19:35 »
Hi,

aus diversen dummen gründen muss ich einen cron einrichten, der an mehreren Tagen im Monat läuft einrichten.

Ich hatte mich als informiert wie es aussehen muss und es eingerichtet. Leider wurde der cron am 8.8.12 nicht ausgeführt.

Mein Cron sieht so aus:

01 07 8 8 * /home/xxxx
01 07 10 8 * /home/xxxx
01 07 15 8 * /home/xxxx
01 07 17 8 * /home/xxxx

mein Wunsch ist also das der cron am 8.8.12, 10.8.12, 15.8.12 und 17.8.12 jeweils um 7:01 ausgeführt wird. Leider scheint das so nicht zu funktionieren. Ich hatte schon öfter mal das Problem, dass ein Linux Cron unter Solaris nicht funktioniert hat.

Das Script an sich funktioniert problemlos und der pfad im cron ist korrekt.

Hat einer von euch einen Tipp für mich?

Danke und Gruß!

sonnenblen.de - Das unabhängige Sun User Forum

Frage zu Cron
« am: 09. August 2012, 10:19:35 »

Offline Ten Little Indyans

  • Sobl Bachelor
  • ***
  • Beiträge: 218
Re: Frage zu Cron
« Antwort #1 am: 09. August 2012, 13:12:10 »
Vielleicht eine blöde Frage, aber tut der Cron-Dienst denn überhaupt? (Läuft /usr/sbin/cron?)

Wenn ja, sind denn irgendwelche Fehlermeldungen in /var/cron/log protokolliert worden?
Hat der User, dessen crontab das ist, vielleicht eine E-Mail vom cron erhalten in der ein Fehler gemeldet wird?

An der gezeigten crontab ist überhaupt nichts auszusetzen.

Offline avalox

  • Sobl Junior
  • **
  • Beiträge: 59
Re: Frage zu Cron
« Antwort #2 am: 09. August 2012, 13:18:28 »
im cron log steht nichts. Kein Aufruf des Scripts

in dem Zeitraum hätte es ja passieren müssen

<  tbmx 1517 c Wed Aug  8 06:50:04 2012
<  tbmx 1459 c Wed Aug  8 06:51:29 2012
>  CMD: /home/bla >/dev/null 2>&1
>  tbmx 1586 c Wed Aug  8 07:00:00 2012
<  tbmx 1586 c Wed Aug  8 07:00:04 2012
>  CMD: cd /opt/blubb
>  gateadm 1606 c Wed Aug  8 07:05:00 2012
<  gateadm 1606 c Wed Aug  8 07:05:11 2012

crons allgemein funktionieren. Eine Mail hab ich nicht erhalten. Hab vorhin mal einen ähnlichen Cron nur mit einem echo in eine Datei erstellt. Der hat einwandfrei funktioniert?!

EDIT: ich hatte gerade zwei ssh sessions offen und hab ins falsche log geschaut. Er wurde doch aufgrufen. Dann muss es wohl irgendwas mit dem Script sein
« Letzte Änderung: 09. August 2012, 13:20:25 von avalox »