Superuser

Autor Thema: Solaris 11 - IPv4 Absende-Adresse bei mehreren konfigurierten Adressen?  (Gelesen 126 mal)

Offline Sonnenbrand

  • Sobl Junior
  • **
  • Beiträge: 84
Hallo Sonnenblende,

ev. hat ja hier jemand eine Idee zu folgendem Problem(chen).



Folgendes Setup:


root@destgsu0010:/var/adm# ipadm
NAME              CLASS/TYPE STATE        UNDER      ADDR
backbone0         ipmp       ok           --         --
   backbone0/v4   static     ok           --         10.220.11.11/24
   backbone0/v4dns static    ok           --         10.220.11.74/24
   backbone0/v4nis static    ok           --         10.220.11.51/24
   backbone0/v4ntp static    ok           --         10.220.11.46/24
lo0               loopback   ok           --         --
   lo0/v4         static     ok           --         127.0.0.1/8
net0              ip         ok           backbone0  --
net1              ip         ok           backbone0  --
root@destgsu0010:/var/adm#




Wie kann ich beeinflussen welche IP-Adresse der Server bei abgehenden Daten (von Ihm imitiert wie zB bei ping oder syslog zu einem sysloghost) als Absende-Adresse nimmt. Aktuell nimmt er die 10.220.11.74, ich hätte aber gerne die 10.220.11.11.



Andi

sonnenblen.de - Das unabhängige Sun User Forum


Offline vab

  • Global Moderator
  • Sobl Master
  • *****
  • Beiträge: 475
Antw:Solaris 11 - IPv4 Absende-Adresse bei mehreren konfigurierten Adressen?
« Antwort #1 am: 15. September 2019, 20:05:58 »
Wie sehen Deine Routen aus?  Eigentlich müßtest Du vier Stück nach 10.220.11.0/24 haben; für jede Adresse eine.  Versuch mal, die anderen drei zu entfernen.

Wenn das nicht hilft, setz mal das "hostmodel" in den IPv4- und IPv6-Parametern auf "strong".  *VORSICHT*: Nicht auf Routern machen...


Gruß -- Volker
Diese Nachricht enthält ausschließlich meine persönliche private Meinung....

Offline Sonnenbrand

  • Sobl Junior
  • **
  • Beiträge: 84
Antw:Solaris 11 - IPv4 Absende-Adresse bei mehreren konfigurierten Adressen?
« Antwort #2 am: 16. September 2019, 11:29:23 »
Hi Volker,

gute idee mit der Routing-Tabelle - aber leider scheitere ich beim löschen der zusätzlichen Einträge. Es kommt immer die meldung "not in table"

Hier das Ganze mal an einem Testsystem:

root@asgard:~# ipadm
NAME              CLASS/TYPE STATE        UNDER      ADDR
backbone0         ipmp       ok           --         --
   backbone0/v4   static     ok           --         10.220.11.39/24
   backbone0/v4a1 static     ok           --         10.220.11.110/24
   backbone0/v4a2 static     ok           --         10.220.11.136/24
   backbone0/v4a3 static     ok           --         10.220.11.137/24
lo0               loopback   ok           --         --
   lo0/v4         static     ok           --         127.0.0.1/8
net0              ip         ok           backbone0  --
net1              ip         ok           sunray0    --
net2              ip         ok           backbone0  --
net3              ip         ok           sunray0    --
sunray0           ipmp       ok           --         --
   sunray0/v4     static     ok           --         10.0.0.2/24
root@asgard:~#
root@asgard:~# netstat -nr

Routing Table: IPv4
  Destination           Gateway           Flags  Ref     Use     Interface
-------------------- -------------------- ----- ----- ---------- ---------
default              10.220.11.254        UG        3   55911410
10.0.0.0             10.0.0.2             U         2          0 sunray0
10.220.11.0          10.220.11.137        U         9       2175 backbone0
10.220.11.0          10.220.11.136        U         6         32 backbone0
10.220.11.0          10.220.11.110        U         3       7701 backbone0
10.220.11.0          10.220.11.39         U        19   13254069 backbone0
127.0.0.1            127.0.0.1            UH        2        962 lo0
root@asgard:~#
root@asgard:~# route delete 10.220.11.0 10.220.11.110
delete host 10.220.11.0: gateway 10.220.11.110: not in table
root@asgard:~# route delete 10.220.11.0 10.220.11.39
delete host 10.220.11.0: gateway 10.220.11.39: not in table
root@asgard:~# route delete -net 10.220.11.0 -gateway 10.220.11.39
delete net 10.220.11.0: gateway 10.220.11.39: not in table
root@asgard:~#
root@asgard:~# uname -a
SunOS asgard 5.11 11.4.12.5.0 sun4v sparc sun4v
root@asgard:~#



Offline vab

  • Global Moderator
  • Sobl Master
  • *****
  • Beiträge: 475
Antw:Solaris 11 - IPv4 Absende-Adresse bei mehreren konfigurierten Adressen?
« Antwort #3 am: 16. September 2019, 11:50:35 »
Tja, da hilft nur das Lesen der Anleitung.  Es gibt ja diverse "address properties", die man mit ipadm setzen kann.  Vermutlich ist da was dabei.   Hab leider grad keine Zeit, es auszuprobieren.


Gruß -- Volker
Diese Nachricht enthält ausschließlich meine persönliche private Meinung....

Offline Sonnenbrand

  • Sobl Junior
  • **
  • Beiträge: 84
Antw:Solaris 11 - IPv4 Absende-Adresse bei mehreren konfigurierten Adressen?
« Antwort #4 am: 16. September 2019, 13:28:25 »
Kein Thema,

bin ja schon froh ein paar Hinweise in mögliche Lösungsrichtungen zu bekommen.

sonnenblen.de - Das unabhängige Sun User Forum


Offline Sonnenbrand

  • Sobl Junior
  • **
  • Beiträge: 84
Antw:Solaris 11 - IPv4 Absende-Adresse bei mehreren konfigurierten Adressen?
« Antwort #5 am: 19. September 2019, 13:15:41 »
Der Vollständighalber kommt hier die Lösung:

Es gibt eine Address-Property deprecated:

Zitat
       deprecated (DHCP, Static, Addrconf, VRRP)

           The address should no longer used as a source address in new commu-
           nications, but packets addressed to this address are  processed  as
           expected. Possible values are on or off. Default is off. This prop-
           erty is not supported on an address object of type dhcp.


Das scheint zu funktionieren:

Zitat
root@asgard:~# ipadm
NAME              CLASS/TYPE STATE        UNDER      ADDR
backbone0         ipmp       ok           --         --
   backbone0/v4   static     ok           --         10.220.11.39/24
   backbone0/v4a1 static     ok           --         10.220.11.110/24
   backbone0/v4a2 static     ok           --         10.220.11.136/24
   backbone0/v4a3 static     ok           --         10.220.11.137/24
lo0               loopback   ok           --         --
   lo0/v4         static     ok           --         127.0.0.1/8
net0              ip         ok           backbone0  --
net1              ip         ok           sunray0    --
net2              ip         ok           backbone0  --
net3              ip         ok           sunray0    --
sunray0           ipmp       ok           --         --
   sunray0/v4     static     ok           --         10.0.0.2/24
root@asgard:~# ipadm show-addrprop -p deprecated
ADDROBJ     PROPERTY         PERM CURRENT         PERSISTENT      DEFAULT         POSSIBLE
lo0/v4      deprecated       rw   off             --              off             on,off
sunray0/v4  deprecated       rw   off             --              off             on,off
backbone0/v4 deprecated      rw   off             --              off             on,off
backbone0/v4a1 deprecated    rw   on              on              off             on,off
backbone0/v4a2 deprecated    rw   on              on              off             on,off
backbone0/v4a3 deprecated    rw   on              on              off             on,off
root@asgard:~#

Mittels tcpdump konnte ich sehen das der Server bei Anfragen auf den "Alias"- Interfacen mit der dort konfigurierten IP antwortet, ansonsten aber immer die "normale" IP-Adresse benutzt. So wie es erwünscht ist.

Andreas

Offline vab

  • Global Moderator
  • Sobl Master
  • *****
  • Beiträge: 475
Antw:Solaris 11 - IPv4 Absende-Adresse bei mehreren konfigurierten Adressen?
« Antwort #6 am: 20. September 2019, 16:50:14 »
Ah, ja.  Braucht man auch bei IPMP-Gruppen je nach Konfiguration.  Der Property-Name fiel mir nicht mehr ein, und ich war zu faul zum Suchen :-)

Schön, daß es jetzt bei Dir geht und danke für das Feedback.


Gruß -- Volker

Diese Nachricht enthält ausschließlich meine persönliche private Meinung....