Superuser

Autor Thema: Solaris 8 syslogd und remote logging... wie?!?  (Gelesen 2827 mal)

Offline Jerry

  • Sobl Administrator
  • Sobl Guru
  • *****
  • Beiträge: 925
  • Let the SUN shine...
    • sonnenblen.de - Das SUN Heimanwender Forum
Solaris 8 syslogd und remote logging... wie?!?
« am: 14. August 2001, 18:37:48 »
Hi,

ich hab meinen "Server" jetzt von Linux auf Solaris 8 umgestellt.
So weit so schön. Bislang loggte mein Server immer brav mit,
was der isdn-Router geloggt haben wollte. Tut er nun nicht mehr.

syslogd im debug-Modus fahren zeigt, dass der router brav
beim syslogd anklopft, aber es wird nix in die logs geschrieben
(default-Zeile für *.* nach /var/adm/other steht in /etc/syslogd.conf)

Was fehlt, damit der syslogd den Ramsch wegschreibt?

Danke

Jerry
Gereon 'Jerry' Stein
Administrator sonnenblen.de

sonnenblen.de - Das unabhängige Sun User Forum

Solaris 8 syslogd und remote logging... wie?!?
« am: 14. August 2001, 18:37:48 »

Offline vab

  • Global Moderator
  • Sobl Master
  • *****
  • Beiträge: 497
Re: Solaris 8 syslogd und remote logging... wie?!?
« Antwort #1 am: 14. August 2001, 21:19:57 »
Hmmm ... sehe ich das richtig, daß der Router remote kommt, also physisch eine andere IP hat?

Das Config-File heißt /etc/syslog.conf, ich nehme aber an, daß es nur ein Typo in Deinem Posting ist.

Einen Eintrag *.* gibt es soweit ich weiß nicht. Nur die Facility kann man als * angeben, nicht den Level. Versuch es doch mal mit dem Facility/Level-Paar, das der Router tatsächlich verwendet.


Viel Erfolg -- Volker
Diese Nachricht enthält ausschließlich meine persönliche private Meinung....

Offline Jerry

  • Sobl Administrator
  • Sobl Guru
  • *****
  • Beiträge: 925
  • Let the SUN shine...
    • sonnenblen.de - Das SUN Heimanwender Forum
Re: Solaris 8 syslogd und remote logging... wie?!?
« Antwort #2 am: 15. August 2001, 00:37:25 »
Hi Volker,

danke, das war's. *.* ist ein gültiges Paar in der Linux-syslog.conf,
aber nicht unter Solaris. Durch trial&error hab ich rausgefunden,
dass der Router auf level "info" sendet. Das facility war nicht
das Problem, da ich von local1-local7 einstellen kann, welches
er selektieren soll.

Seit der richtige Level drinsteht, loggt er wie'ne Eins ;)

Jetzt noch squid auf die U2 bügeln, dann steht das neue
Serverlein (samba mit SWAT konfigurieren ist so richtig
schön dekadent...)

Vielen Dank für den Hinweis!

Gruss

Jerry
Gereon 'Jerry' Stein
Administrator sonnenblen.de