Bei anderen User und auf localhost bekomme ich die selbe Fehlermeldung.
Also ein generelles Problem mit ftp und kein User abhaengiges - damit sind wir doch schon mal ein Stueck weiter.
wie konnte ich das loggin für ftp nochmal einschalten?
Siehe unten ..
Gruss
Bernd
*** Solaris[TM] 10 Operating System: Enabling FTP logging
1.) Confirm $EDITOR is set to vi
# echo $EDITOR
/usr/bin/vi
Note. $EDITOR maybe set to dtpad. You can use dtpad inplace of vi if your prefer.
To modify $EDITOR for vi
If using Bourne shell (/bin/sh).
# EDITOR=/usr/bin/vi;export EDITOR
# echo $EDITOR
/usr/bin/vi
If using C shell (/bin/csh).
% setenv EDITOR /usr/bin/vi
% echo $EDITOR
/usr/bin/vi
2.) Add 'daemon.info' entry to /etc/syslog.conf
*.err;kern.notice;auth.notice /dev/sysmsg
*.err;kern.debug;daemon.notice;mail.crit /var/adm/messages
daemon.info <Use tabs for spaces here only> /var/adm/ftp.log
3.) Create ftp.log file to capture ftp sessions.
# touch /var/adm/ftp.log
4.) Restart syslogd to read new change to syslog.conf.
# kill -HUP <syslogd pid>
5.) Modify ftp line in inetd_start property group.
# svccfg -s ftp editprop
Uncomment the ftp line then add -l to end.
Before
# setprop inetd_start/exec = astring: ("/usr/sbin/in.ftpd -a")
After
setprop inetd_start/exec = astring: ("/usr/sbin/in.ftpd -a -l")
6.) Reload the ftp and inetd manifest.
# svcadm refresh ftp
# svcadm refresh inetd
7.) Confirm in.ftpd is in log mode and ftp.log is actively logging.
# ftp localhost
Connected to localhost.
220 <localhost name> FTP server ready.
Name (localhost:<user>):
In another window check if in.ftpd is in log mode.
# ps -ef | grep ftp
root 13732 9045 1 16:13:01 ? 0:00 /usr/sbin/in.ftpd -a -l
root 13733 13725 0 16:13:05 pts/5 0:00 grep ftp
Check if ftp.log is actively logging sessions.
# more /var/adm/ftp.log
Sep 11 10:31:32 nsh-sb100-16 ftpd[8185]: [ID 532633 daemon.notice] FTP LOGIN REFUSED (username in /etc/ftpd/ftpusers) FROM xxx.xxx.xxx.xxx [xxx.xxx.xxx.xxx], root
Sep 11 10:31:40 nsh-sb100-16 ftpd[8185]: [ID 528697 daemon.info] FTP session closed
Done.