Superuser

Autor Thema: Solaris 10 auf einer Netra T1 bootet im Kreis  (Gelesen 5322 mal)

Offline signal_15

  • Sobl Master
  • ****
  • Beiträge: 426
    • Rechenzentrum Amper
Solaris 10 auf einer Netra T1 bootet im Kreis
« am: 26. März 2012, 18:52:39 »
'n Abend,

folgendes problem habe ich. meine netra bootet und macht sofort einen reset. was kann das problem sein? eine defekte festplatte?
ok boot -v
Initializing Memory
Boot device: /pci@1f,0/pci@1,1/scsi@2/disk@0,0:a  File and args: -v
module /platform/sun4u/kernel/sparcv9/unix: text at [0x1000000, 0x10a8cb5] data at 0x1800000
module /platform/sun4u/kernel/sparcv9/genunix: text at [0x10a8cb8, 0x1286e77] data at 0x1866fc0
module /platform/sun4u/kernel/misc/sparcv9/platmod: text at [0x1286e78, 0x1286e7f] data at 0x18bda80
module /platform/sun4u/kernel/cpu/sparcv9/SUNW,UltraSPARC-IIi: text at [0x1286e80, 0x1293287] data at 0x18be180

SunOS Release 5.10 Version Generic_142909-17 64-bit
Copyright (c) 1983, 2010, Oracle and/or its affiliates. All rights reserved.
avail mem = 503971840
root nexus = Netra t1 (UltraSPARC-IIi 440MHz)
pseudo0 at root
pseudo0 is /pseudo
scsi_vhci0 at root
scsi_vhci0 is /scsi_vhci
pcipsy0 at root: UPA 0x1f 0x0
pcipsy0 is /pci@1f,0
PCI-device: pci@1,1, simba0
simba0 is /pci@1f,0/pci@1,1
/pci@1f,0/pci@1,1/scsi@2 (glm0):
Rev. 3 Symbios 53c875 found.
PCI-device: scsi@2, glm0
glm0 is /pci@1f,0/pci@1,1/scsi@2
sd2 at glm0: target 0 lun 0
sd2 is /pci@1f,0/pci@1,1/scsi@2/sd@0,0
root on /pci@1f,0/pci@1,1/scsi@2/disk@0,0:a fstype ufs
pseudo-device: dld0
dld0 is /pseudo/dld@0
PCI-device: ebus@1, ebus0
ebus0 is /pci@1f,0/pci@1,1/ebus@1
su0 at ebus0: offset 14,3803f8
su0 is /pci@1f,0/pci@1,1/ebus@1/su@14,3803f8
cpu0: UltraSPARC-IIi (portid 0 impl 0x12 ver 0x91 clock 440 MHz)
iscsi0 at root
iscsi0 is /iscsi
The / file system (/dev/rdsk/c0t0d0s0) is being checked.
Hostname: unknown
syncing file systems... done
rebooting...
Resetting ...

ich habe bereits uebers netzwerk einen boot zu stande gebracht und die platte mounten koennen. in /var/log/messages steht nur der letzte shutdown drinnen. irgendeinen tip wie ich dem problem auf die schliche kommen koennte?

ct,

sonnenblen.de - Das unabhängige Sun User Forum

Solaris 10 auf einer Netra T1 bootet im Kreis
« am: 26. März 2012, 18:52:39 »

Offline signal_15

  • Sobl Master
  • ****
  • Beiträge: 426
    • Rechenzentrum Amper
Re: Solaris 10 auf einer Netra T1 bootet im Kreis
« Antwort #1 am: 26. März 2012, 19:54:45 »
bin ratlos.-(
# fsck /dev/dsk/c0t0d0s0
** /dev/rdsk/c0t0d0s0
** Last Mounted on /
** Phase 1 - Check Blocks and Sizes
** Phase 2 - Check Pathnames
** Phase 3a - Check Connectivity
** Phase 3b - Verify Shadows/ACLs
** Phase 4 - Check Reference Counts
** Phase 5 - Check Cylinder Groups
315550 files, 8970088 used, 99219487 free (29831 frags, 12398707 blocks, 0.0% fragmentation)

ct,

Offline Drusus

  • Sobl Master
  • ****
  • Beiträge: 424
  • Intentionally left blank
Re: Solaris 10 auf einer Netra T1 bootet im Kreis
« Antwort #2 am: 26. März 2012, 20:15:35 »
Moin,

sieht fuer mich so aus als ob irgendein anderer Service spaeter ein reboot initiiert.
Hast du kuerzlich neue Software installiert?

Ansonsten wuerde ich mal ein "boot -s" probieren und dann mal manuall die einzelnen Services starten um zu sehen welcher den Reboot ausloest.

Tschau,
  Drusus.

Offline signal_15

  • Sobl Master
  • ****
  • Beiträge: 426
    • Rechenzentrum Amper
Re: Solaris 10 auf einer Netra T1 bootet im Kreis
« Antwort #3 am: 26. März 2012, 20:46:11 »
auch ein boot in den single user mode endet in einem reset/reboot. das war eins der ersten sachen die ich versucht habe. nein, in den letzten wochen ist keine software hinzu gekommen. letzte woche habe ich ein paar php packete von opencsw aktualisiert. aber das war es auch schon.

ct,

Offline Drusus

  • Sobl Master
  • ****
  • Beiträge: 424
  • Intentionally left blank
Re: Solaris 10 auf einer Netra T1 bootet im Kreis
« Antwort #4 am: 27. März 2012, 11:35:02 »
Moin.

wenn selbst ein boot -s schon ein reboot loop macht, dann wundert mich das schon (da der Reboot ja erst spaeter im BootProzess kommt)).
Probier mal ein "boot -m milestone=none"wo dann wirklich gar keine Services gestartet werden. Dann ist aber selbst / noch read-only.
Wenn das geht, dann hast du zumindest einen Ausgangzpunkt um dann von dort aus die Services einzeln zu starten um zu sehen wo es knallt.

Tschau,
  Drusus.

Offline signal_15

  • Sobl Master
  • ****
  • Beiträge: 426
    • Rechenzentrum Amper
Re: Solaris 10 auf einer Netra T1 bootet im Kreis
« Antwort #5 am: 27. März 2012, 13:56:39 »
Mahlzeit,

ha, die kiste ist tatsaechlich oben geblieben.
ok boot -m milestone=none
Boot device: /pci@1f,0/pci@1,1/scsi@2/disk@0,0:a  File and args: -m milestone=no                                            ne
SunOS Release 5.10 Version Generic_142909-17 64-bit
Copyright (c) 1983, 2010, Oracle and/or its affiliates. All rights reserved.
Booting to milestone "none".
Requesting System Maintenance Mode
(See /lib/svc/share/README for more information.)
Console login service(s) cannot run

Root password for system maintenance (control-d to bypass):
single-user privilege assigned to /dev/console.
Entering System Maintenance Mode

Mar 27 13:52:38 su: 'su root' succeeded for root on /dev/console
#

wie geht's nun weiter? das /etc/init.d verzeichniss hatte ich schon vorher leer gemacht um alle dienste die mittels startskript hoch kommen am start zu hindern. wie starte ich nun einen dienst nach dem anderen der mittels smf hoch kommen sollte?

ct,

Offline signal_15

  • Sobl Master
  • ****
  • Beiträge: 426
    • Rechenzentrum Amper
Re: Solaris 10 auf einer Netra T1 bootet im Kreis
« Antwort #6 am: 27. März 2012, 14:28:33 »
ich vermute, dass da noch mehr im argen ist.
ok boot -m milestone=none
Boot device: /pci@1f,0/pci@1,1/scsi@2/disk@0,0:a  File and args: -m milestone=none
Fast Data Access MMU Miss
ok

ist es nur die festplatte oder etwas anderes?

ct,

Offline Drusus

  • Sobl Master
  • ****
  • Beiträge: 424
  • Intentionally left blank
Re: Solaris 10 auf einer Netra T1 bootet im Kreis
« Antwort #7 am: 28. März 2012, 13:28:35 »
Moin,

die einzelnen Startscripte lassen sich mit "svcadm enable -t <name>" einzeln aktivieren (mit "svcs -a" kann man sehen welche es alles gibt).

Der Fehler mit MMU miss deutet in der Tat eher auf ein Hardware-Problem hin. Dann kann die Disk aber auch RAM oder PCU sein.
Dazu wurde ich empfehlen im OBP den diag-level auf max zu setzen und dann einen kompletten power-cycle zu machen.
Hast du schon im LOM nachgesehen ob dort "show eventlog" oder "loghistory" einen Hinweis gibt?

Tschau,
  Drusus.

Offline Sparky

  • Sobl Guru
  • *****
  • Beiträge: 3260
  • HyperSPARC ! Das fetzt......
    • HyperSTATION
Re: Solaris 10 auf einer Netra T1 bootet im Kreis
« Antwort #8 am: 28. März 2012, 17:03:57 »
Hi,
 
Fast Data Access MMU Miss

als erstes alles Speicherriegel entnehmen und die Kontakte mit einem Radiergummi reinigen.
Danach die Mindestanzahl einsetzen und booten...
Wenn alles gut ist, dann Speicher für Speicher einsetzen und immer wieder booten dazwischen.
So bekommt man es gleich mit, falls doch einer hinüber ist.
Gruss
Jürgen
www.hyperstation.de
alles zu HyperSPARC, SBus-Karten und AG-10E Howto

Offline signal_15

  • Sobl Master
  • ****
  • Beiträge: 426
    • Rechenzentrum Amper
Re: Solaris 10 auf einer Netra T1 bootet im Kreis
« Antwort #9 am: 30. März 2012, 11:36:05 »
dieser 'mmu miss' fehler war wohl eine einmalige sache. ich habe ihn nicht mehr reproduzieren koennen. dafuer habe ich dann "freya uata: WARNING: timeout: reset target chno = 1 targ = 2" fehler bekommen die nach einem reset aber auch wieder weg waren. anscheinend hatte sich das cdrom kurz verabschiedet.

ich habe die erste platte getauscht, solaris10 bereits installiert und bin gerade dabei die sicherung zurueck zu schreiben. irgendwo habe ich noch eine andere netra. da werde ich mal die originale platte reinschieben und sehen was passiert.

ct,

sonnenblen.de - Das unabhängige Sun User Forum

Re: Solaris 10 auf einer Netra T1 bootet im Kreis
« Antwort #9 am: 30. März 2012, 11:36:05 »