Superuser

Autor Thema: Mit cygwin auf Solaris 8  (Gelesen 4192 mal)

reni

  • Gast
Mit cygwin auf Solaris 8
« am: 14. August 2012, 15:57:58 »
Hallo Leute,

ganz komisches Problem ...  ???

Ich kann mich mit cygwin auf Solaris 8 und OpenWindows Desktop verbinden. Alles gut.

Aber ... ich kann mich nicht am CDE anmelden.
D.h. Login funzt und CDE versucht auch zu starten, bricht aber ab und mein cygwin-Fenster schließt sich einfach.
Und ich kann nirgends hilfreiche Einträge in Log-Files entdecken.

Hat von euch jemand eine Idee, woran das liegen kann?

So lautet der Aufruf (eine.bat) mit Cygwin:
set SERVERNAME=<server>
set DISPLAY=:2
start XWin %DISPLAY% -fp tcp/%SERVERNAME%:7100 -query %SERVERNAME% -once

Cygwin installiert in Version 2.738 (setup.exe)
Cygwin/X-Server Version: 1.12.3

EDIT: Der Client ist ein Windows 7

Danke!
Gruß reni

« Letzte Änderung: 15. August 2012, 14:38:56 von reni »

sonnenblen.de - Das unabhängige Sun User Forum

Mit cygwin auf Solaris 8
« am: 14. August 2012, 15:57:58 »

Offline Ten Little Indyans

  • Sobl Bachelor
  • ***
  • Beiträge: 218
Re: Mit cygwin auf Solaris 8
« Antwort #1 am: 16. September 2012, 17:40:33 »
Es dürfte an fehlenden Zeichensätzen liegen, wobei mir nicht klar ist wie das bei Verwendung des Font-Servers der Solaris 8 Kiste überhaupt sein kann.

Ich hatte endlich mal wieder Gelegenheit meine Netra anzuschmeissen und konnte das Problem an sich nachvollziehen (Cygwin Xnest auf Windows XP und Solaris 8 2/04).

Zum Thema Log-Files: Siehe $HOME/.dt/startlog oder auch $HOME/.dt/sessionlogs/* auf dem Server.

Zitat von: startlog
X Error of failed request:  BadAlloc (insufficient resources for operation)
  Major opcode of failed request:  45 (X_OpenFont)
  Serial number of failed request:  63
  Current serial number in output stream:  64

Also ein Problem beim Öffnen eines Fonts.  Zumindest bei mir (ohne Fontserver) lag es daran, dass dem Cygwin X-Server bestimmte Fonts nicht bekannt waren, z.B. -dt-interface system-medium-r-normal-m sans-17-170-72-72-p-97-iso 8859-1.

Bei den -dt-interface system Fonts handelt es sich allesamt um Aliase, siehe /usr/openwin/lib/X11/fonts/F3bitmaps/fonts.alias. Ich habe sie einfach dem Cygwin X-Server bekanntgemacht (xset fp) und schon läuft der CDE Desktop.

Eigentlich sollte aber die Verwendung des Fontservers genau dieses Problem verhindern. ???  Oder ist er so konfiguriert dass er die F3 Fonts gar nicht ausliefert?  Ist die o.g. fonts.alias Datei auf Deinem Solaris-System vorhanden?

reni

  • Gast
Re: Mit cygwin auf Solaris 8
« Antwort #2 am: 17. September 2012, 10:15:23 »
Hallo und Danke für die Antwort,

leider brauchten wir eine "schnelle" Lösung und so wurde beschlossen Exceed-Lizenzen zu beschaffen und Exceed zu benutzen.
Damit funzte alles sofort ;)

Offline vab

  • Global Moderator
  • Sobl Master
  • *****
  • Beiträge: 488
Re: Mit cygwin auf Solaris 8
« Antwort #3 am: 20. September 2012, 13:59:40 »
Exceed?  Seufz...

Teste doch spaßeshalber mal:

  http://www.mochasoft.dk/freeware/x11.htm

Gruß -- Volker
Diese Nachricht enthält ausschließlich meine persönliche private Meinung....