Superuser

Autor Thema: NetBSD MultiProzessoring  (Gelesen 28281 mal)

Lordy

  • Gast
NetBSD MultiProzessoring
« am: 26. September 2002, 00:13:46 »
Hey,

hier mal ein neuer Thread fuer das Thema NetBSD MP.

Also ich hab ein paar infos zum Thema zusammen getragen, die ich hier mal niederschreiben :) .

1.) Bei NetBSD 1.6 ist MP noch kein Fixxer bestandteil, und es muss deswegen der Kernel gepatched werden.

2.) Auf x86 Systemen laeuft MP schon zimlich stabil und ohne groessere Probleme. Wenn es wem interessiert wie man unter einen x86 System MP zum laufen bringt sollte er sich hier melden, da sollte ich eigendlich helfen koennen 8)

3,1.) Arch SPARC SuperSparc: Bei Systemen mit einen SuperSparc sollte es auch laufen, leider kann ich das nicht testen da ich kein sollchen System habe, und weiter helfen dabei kann ich auch nicht, weil ich wirklich nichts dazu gefunden hab ausser "it run!!" ... ::)

3,2.) Arch SPARC HyperSparc: Bei Systemen mit HyperSparc CPU's ist die Sache schon etwas heickler, da diese cpu's anscheinent eine andere Cache-Controll haben und diese noch nicht richtig laeuft. Es wurde zwar mal einige Monate lang darueber gesprochen, und etwas rum gehackt, aber ich habe keine Informationen zu einen endgueltigen Erbnis finden koennen.

4.) Arch. SPARC64: Hier ist die Sache recht einfach: Es laeuft nocht nicht  :'(


Gruss,
chris
« Letzte Änderung: 26. September 2002, 00:17:10 von Lordy »

sonnenblen.de - Das unabhängige Sun User Forum

NetBSD MultiProzessoring
« am: 26. September 2002, 00:13:46 »

Lordy

  • Gast
Re: NetBSD MultiProzessoring
« Antwort #1 am: 02. Oktober 2002, 01:15:12 »
Hey,

heute wurde die Patch fuer x86 MP in NetBSD-current aufgenommen, also faeld in zukunft schon mal die Patch arbeit weg.

MP ist bei NetBSD auch auf den Alpha und VAX Port lauffaehig. Ach ja, der Mac Port ist nich zu vergessen, da ist MP aber noch sehr jung.


Gruss,
chris

Stefan

  • Gast
Re: NetBSD MultiProzessoring
« Antwort #2 am: 02. Oktober 2002, 22:53:43 »
ich wollte noch mal genauer auf die sparcys eingehen:

options       MULTIPROCESSOR            # include multiprocessor support

mainbus0 at root
cpu0      at mainbus0
cpu*       at mainbus0            # declare additional CPUs

ist schon genug um mp betrieb aufzunehmen, ich habe das von
der GENERIC.MP in meine file übernommen...

mfg, stefan

Lordy

  • Gast
Re: NetBSD MultiProzessoring
« Antwort #3 am: 02. Oktober 2002, 23:11:09 »
@stefan: nicht mehr nötig? kein patchen?
Was ich mich noch frage, braucht man -current oder hast du das relase-1.6?


chris

Lordy

  • Gast
Re: NetBSD MultiProzessoring
« Antwort #4 am: 02. Oktober 2002, 23:22:07 »
Man merkt ich werde alt - und das schon in so jungen Jahren ;)
Ein blick nach /usr/src/sys/arch/sparc/conf beantwortet meine Fragen schon ..

Kein Patchen ist mehr nötig, und ja, es ist schon in relase-1.6 drinnen.


chris

Stefan

  • Gast
Re: NetBSD MultiProzessoring
« Antwort #5 am: 03. Oktober 2002, 15:40:54 »
sorry, konnte nich früher antworten :)
wie gesagt, ich hab mir die 2 zeilen einfach aus GENERIC.MP
geholt, dann compilierst das einfach rein und fertig (1.6 stable)

.. aber hast ja eh schon bemerkt :)

mfg,stefan

friday

  • Gast
Re: NetBSD MultiProzessoring
« Antwort #6 am: 04. Oktober 2002, 05:31:41 »
klingt fuer mich als ob sich meine ss20 bald von solaris trennen muesste.  ;)

ich lasse mich ueberraschen und werden mal berichten wie meine ss20 verhaelt.

friday

friday

  • Gast
Re: NetBSD MultiProzessoring
« Antwort #7 am: 06. Oktober 2002, 16:04:58 »
moin,

1.6 aus dem netz gezogen, auf cd gebannt, installiert, konfiguriert, kernel kompiliert und gebootet. alles kein problem ...

aber wie sag ich netbsd, das ein proggi auf der 2. cpu laufen soll?

friday

Lordy

  • Gast
Re: NetBSD MultiProzessoring
« Antwort #8 am: 06. Oktober 2002, 16:28:19 »
Hey,

du sagst das NetBSD gar nicht. NetBSD ist selbst dafür zuständig die Prozesse auf die zur Verfühgung stehenden CPU's aufzuteilen (das macht der Scheduler).

Wenn du mehr Prozesse startest und dir dann die Sache mit 'top' anguckst solltest du eigendlich auch sehen auf welchen CPU's welcher Prozess läuft.

Gruss,
chris

friday

  • Gast
Re: NetBSD MultiProzessoring
« Antwort #9 am: 06. Oktober 2002, 17:33:02 »
genau da liegt mein problem,

es laufen alle auf der ersten, bisher sagt mir top immer auf CPU/0.
sind sie bei sun4m noch nicht soweit oder habe ich was vergessen?

friday

sonnenblen.de - Das unabhängige Sun User Forum

Re: NetBSD MultiProzessoring
« Antwort #9 am: 06. Oktober 2002, 17:33:02 »

Stefan

  • Gast
Re: NetBSD MultiProzessoring
« Antwort #10 am: 06. Oktober 2002, 17:41:14 »
hast du einen kernel mit den von mir oben geposteten
options ?

mfg, stefan

Offline Sparky

  • Sobl Guru
  • *****
  • Beiträge: 3260
  • HyperSPARC ! Das fetzt......
    • HyperSTATION
Re: NetBSD MultiProzessoring
« Antwort #11 am: 06. Oktober 2002, 17:45:08 »
Bei Linus-Distris ist immer ein SMP-Kernel fällig.
NetBSD habe ich noch nicht ausprobiert.
Aber ich denke, daß SMP im Kernel ausgewählt/enabled werden muß.
www.hyperstation.de
alles zu HyperSPARC, SBus-Karten und AG-10E Howto

Stefan

  • Gast
Re: NetBSD MultiProzessoring
« Antwort #12 am: 06. Oktober 2002, 18:17:58 »
gut doch bei antwort #2 - das sind die optionen, die mit
in kernel reincompiliert werden müssen...

mfg, stefan

Lordy

  • Gast
Re: NetBSD MultiProzessoring
« Antwort #13 am: 06. Oktober 2002, 18:39:47 »
Hey,

also wie gesagt, wenn du die Sachen die Stefan gepostet hat in deinen kernel drin hast, sollte es funktionieren.

mach mal "dmesg | grep 'cpu'", das sollte dir anzeigen welche CPU's das System gefunden hat beim booten. Wenn nur eine, dann hast du nenn fehler gemacht beim Kernel bauen, wenn zwei, dann hast du dich vielleicht bei top verguckt - sonst feld mir jetzt kein fehler mehr ein.

chris

friday

  • Gast
Re: NetBSD MultiProzessoring
« Antwort #14 am: 06. Oktober 2002, 20:53:00 »
hab mich eigentlich nicht verguckt:

dmesg:
.
.
.
cpu0 at mainbus0: mid 8: TMS390Z50 v0 or TMS390Z55 @ 75 MHz, on-chip FPU
cpu0: physical 20K instruction (64 b/l), 16K data (32 b/l), 1024K external (32 b/l): cache enabled
cpu1 at mainbus0: mid 10: TMS390Z50 v0 or TMS390Z55 @ 75 MHz, on-chip FPU
cpu1: physical 20K instruction (64 b/l), 16K data (32 b/l), 1024K external (32 b/l): cache enabled
.
.
.
cpu0: booting secondary processors: cpu1


soweit so gut ... alle prozesse die ich anstarte laufen dann in top mit xxx/0 und die min. cpu idle betraegt 50%.

???  ???  ???

ok, hab mir gerade den aktuellen syssrc per cvs gezogen, mal sehen was passiert wenn er fertig compiliert ist...

friday
« Letzte Änderung: 06. Oktober 2002, 20:57:05 von friday »