Superuser

Autor Thema: Intel WLan2915ABG konfigurieren  (Gelesen 4871 mal)

k-star

  • Gast
Intel WLan2915ABG konfigurieren
« am: 15. Dezember 2008, 21:54:27 »
Hallo,
muss direkt sagen ich bin ein Linux Nutzer der mal was anderes testen will.

Habe das Problem das meine Intel WLAN Karte 2915ABG als E1000 Ethernet Adapter behandelt wird.
Habe die E1000 Karte bereits im BIOS deaktiviert, aber leider ohne Veränderung.

# /usr/X11/bin/scanpci
pci bus 0x0002 cardnum 0x02 function 0x00: vendor 0x8086 device 0x4224
 Intel Corporation PRO/Wireless 2915ABG [Calexico2] Network Connection

/boot/solaris/devicedb/master
Die Intel WLan Karte ist mit der PCI Kennung als iwi eingetragen.

# ifconfig iwi0 plumb
ifconfig: cannot open link "iwi0": DLPI link does not exist

# ifconfig -a plumb
ohne Meldung

# modload iwi
can't load module: No such file or directory

Wobei laut Paketmanager die Module für iwi installiert sein sollen
unter /dev/drv liegt auch eine Datei mit iwi

Von /dev/e1000g zeigt ein Link auf /devices/pseudo/clone@0:e1000g
einen ähnlichen Link für iwi gibt es nicht.

# devfsadm -i iwi
devfsadm: driver failed to attach: iwi

Nutze ich die interne E1000 mit DHCP funktioniert das ganze Out-Of-Box.

Kann man in ON irgendwo einstellen, dass er iwi für die 2915ABG nutzen soll?
Muss vielleicht irgendwo ein Link gesetzt werden?

Im Anhang hab ich mal die Ansicht vom Device Manager gehängt, ich denke damit ist klar was ich meine.

sonnenblen.de - Das unabhängige Sun User Forum

Intel WLan2915ABG konfigurieren
« am: 15. Dezember 2008, 21:54:27 »

Offline DukeNuke2

  • Sobl Guru
  • *****
  • Beiträge: 571
  • Soulman
    • Wo die Sonne lacht
Re: Intel WLan2915ABG konfigurieren
« Antwort #1 am: 15. Dezember 2008, 22:30:18 »
was sagt denn der output von "dladm show-dev"?

claus

  • Gast
Re: Intel WLan2915ABG konfigurieren
« Antwort #2 am: 15. Dezember 2008, 22:33:19 »
Hallo,

was benutzt Du denn? Solaris oder OpenSolaris?

Es kann gut sein, dass der Chipsatz noch nicht unterstützt wird:

http://www.sun.com/bigadmin/hcl/data/os/components/views/wifi_all_results.page1.html

Wobei die Liste auch noch nicht so super viel aussagt.

Claus

k-star

  • Gast
Re: Intel WLan2915ABG konfigurieren
« Antwort #3 am: 16. Dezember 2008, 07:41:15 »
Hallo,
sorry gestern Abend ganz vergessen OpenSolaris 2008.11.
dladm show-dev werde ich heute Abend mal testen.
Also die 2915ABG soll mit dem Treiber der 2200BG arbeiten, da die Karte wohl nur um 802.11a erweitert ist.
Im Paketmanager ist die 2915ABG auch unter dem iwi Modul aufgeführt.

k-star

  • Gast
Re: Intel WLan2915ABG konfigurieren
« Antwort #4 am: 16. Dezember 2008, 19:35:16 »
Hallo Freunde der Sonne,
also mit der 2915ABG gibt "dladm show-dev" nichts aus.
Habe jetzt mal eine 2200BG getestet, die funktioniert sofort.
Ich habe auch nochmal die Paketbeschreibung studiert, da wird im SUNWiwi Paket die 2915ABG ausdrücklich als unterstützt bezeichnet neben der 2200BG. Unter Linux nutzen auch beide Karten das gleiche Modul.
Der einzige Unterschied ist dass die 2915ABG eine gelabelte IBM Karte ist und die 2200BG eine Original Intel. Man muss dazu sagen dass IBM seinerzeit die eigenen Karten markiert hat, damit auch niemand normale miniPCI Karten nutzen kann.

claus

  • Gast
Re: Intel WLan2915ABG konfigurieren
« Antwort #5 am: 16. Dezember 2008, 20:21:48 »
Ok, wenn die 2915ABG laut Paket unterstützt wird, ist das entweder ein Bug im Code oder in der Dokumentation :)


k-star

  • Gast
Re: Intel WLan2915ABG konfigurieren
« Antwort #6 am: 21. Dezember 2008, 11:47:32 »
Nachdem ich mal die messages durchgesehen habe, fand ich folgendes

/var/adm/messages
e1000g: [ID 801725 kern.warning] WARNING: pci8086,1013 - e1000g[1] : Identify hardware failed

dannach habe ich mal die /etc/driver_aliases editiert
iwi "pci8086,1013"
#e1000g "pci8086,1013"

und schon funktioniert die 2915ABG Karte, nur die E1000 wird dann wieder mit iwi versucht zu konfigurieren.

wenn ich die /etc/driver_aliases folgendermaßen editiere
#iwi "pci8086,1013"
iwi "pci8086,1010"
e1000g "pci8086,1013"
#e1000g "pci8086,1010"

wird für die 2915ABG das e1000g Modul genutzt und für die E1000 das iwi Modul, beide sind im Status misconfigured.

k-star

  • Gast
Re: Intel WLan2915ABG konfigurieren
« Antwort #7 am: 21. Dezember 2008, 21:14:12 »
scanbus -v liefert folgendes Ergebnis:
pci bus 0x0002 cardnum 0x01 function 0x00: vendor 0x8086 device 0x101e
 Intel Corporation 82540EP Gigabit Ethernet Controller (Mobile)
 CardVendor 0x1014 card 0x0549 (IBM Thinkpad)

pci bus 0x0002 cardnum 0x02 function 0x00: vendor 0x8086 device 0x4224
 Intel Corporation PRO/Wireless 2915ABG [Calexico2] Network Connection
 CardVendor 0x8086 card 0x1013 (Intel Corporation, Card unknown)

daraufhin habe ich die driver_aliases wieder editiert, diesmal mit Sub-ID:
iwi "pci8086,4224.8086.1013"
e1000g "pci8086,101e.1014.0549"

In dieser Konstellation funktioniert die 2915ABG, aber die E1000 ist wieder im Status misconfigured mit iwi.
Da mir langsam die Ideen ausgehen und die 2915ABG nur die DE Kanale anzeigt, aber eine FRU (IBM-Nummer) für den japanischen Markt hat, vermute ich dass da mal jemand am EEPROM auf der Karte was verändert hat. Ich glaube diese eine Karte würde unter Solaris nur funktionieren wenn man die Sub-ID verändert.